1

Closed

sql errorsql error

description

Failure SQL Execution resulted in following Exceptions: System.Data.SqlClient.SqlException (0x80131904): The multi-part identifier "Users.UserId" could not be bound. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning() at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader
dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result,
String methodName, Boolean sendToPipe) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at DotNetNuke.Data.SqlDataProvider.ExecuteADOScript(String SQL) at DotNetNuke.Data.SqlDataProvider.ExecuteScript(String Script, Boolean UseTransactions) create procedure
dbo.dnn_Softwaresedge_GetHTMLRepeatersPaged @ModuleId int, @pageNumber int, @pageSize int as With Repeaters as ( select ROW_Number()Over(order by DisplayOrder,itemId asc) as RowNum, ModuleId, ItemId, Content, DisplayOrder, CreatedByUser, CreatedDate, 'CreatedByUserName'
= dnn_Users.FirstName + ' ' + dnn_Users.LastName, AnchorText from dnn_Softwaresedge_HTMLRepeater inner join dnn_Users on dnn_Softwaresedge_HTMLRepeater.CreatedByUser = Users.UserId where ModuleId = @ModuleId ) select ModuleId, ItemId, Content, DisplayOrder,
CreatedByUser, CreatedDate, CreatedByUserName, AnchorText from Repeaters where RowNum Between ((@pageNumber - 1) * @pageSize + 1) and (@pageNumber * @pageSize) order by DisplayOrder,itemId asc
Closed Jan 6, 2011 at 2:56 PM by jcassel
Updated and released in 01.00.02 C

comments

jcassel wrote Jan 6, 2011 at 10:57 AM

There is an issue with a proc that it is missing the prefix for your database tables. from the stack trace it looks like you have a {objectQualifier} of "dnn_". I think there must be a sp that is missing the {objectQualifier}

I have just posted a new build that corrects this issue. please download and install it. (01.00.02C). Let me know if you are still having issues.

wrote Jan 6, 2011 at 2:56 PM

wrote Feb 13, 2013 at 7:43 PM

wrote May 15, 2013 at 3:42 AM